Page 1 of 1

Need to register often

Posted: Thu Aug 10, 2017 7:54 am
by snapper
Not sure if this is normal but I need to fill in my mail address at the start of PSS often. I guess about every 5 times starting the program, so sometimes I need to to register at start every few days.

Using Ubuntu 16.04. BTW thanks for bringing PSS to Linux, it works so smooth!!

Re: Need to register often

Posted: Sun Aug 13, 2017 9:13 am
by support
Try to disable internet access to Paintstorm after the registration complete. (firewall or other defence software)

Re: Need to register often

Posted: Wed Aug 16, 2017 3:55 am
by HeroicNate
I also have that issue. Guess I will try disabling it's internet access.

Re: Need to register often

Posted: Fri Aug 18, 2017 12:46 pm
by Ico-dY
snapper wrote:Not sure if this is normal but I need to fill in my mail address at the start of PSS often. I guess about every 5 times starting the program, so sometimes I need to to register at start every few days.

Using Ubuntu 16.04. BTW thanks for bringing PSS to Linux, it works so smooth!!


After registration install firejail and make a shortcut with "firejail --noprofile --net=none /usr/share/paintstorm/Paintstorm" as executable. It works for me. ;)

Re: Need to register often

Posted: Sat Aug 19, 2017 1:28 pm
by snapper
Ico-dY wrote:
snapper wrote:Not sure if this is normal but I need to fill in my mail address at the start of PSS often. I guess about every 5 times starting the program, so sometimes I need to to register at start every few days.

Using Ubuntu 16.04. BTW thanks for bringing PSS to Linux, it works so smooth!!


After registration install firejail and make a shortcut with "firejail --noprofile --net=none /usr/share/paintstorm/Paintstorm" as executable. It works for me. ;)


Thanks for the tip, I'll try this.

The "disable internet access..." trick didn't work. Maybe it means to always disable internet access when using PSS, would be a funny thing to do.
I made a desktop file now with firejail command. I suppose this command blocks PSS internet access?

Re: Need to register often

Posted: Tue Aug 29, 2017 1:21 pm
by Ico-dY
snapper wrote:
Ico-dY wrote:
snapper wrote:
The "disable internet access..." trick didn't work. Maybe it means to always disable internet access when using PSS, would be a funny thing to do.
I made a desktop file now with firejail command. I suppose this command blocks PSS internet access?


Yes, firejail always blocks the PSS connections. Click on other->help in PSS to test firejail. The browser shouldn't work because the child process is blocked as well.

Re: Need to register often

Posted: Tue Aug 29, 2017 8:27 pm
by HeroicNate
Funny this got posted today I just discovered firejail. I'm going to give that a shot.

Re: Need to register often

Posted: Thu Aug 31, 2017 1:57 am
by HeroicNate
Ico-dY wrote:After registration install firejail and make a shortcut with "firejail --noprofile --net=none /usr/share/paintstorm/Paintstorm" as executable. It works for me. ;)


I tried this but get error:
** (Paintstorm:2): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus: Connection refused


Then it fails to load...

Re: Need to register often

Posted: Thu Aug 31, 2017 2:09 am
by HeroicNate
Ico-dY wrote:
snapper wrote:Not sure if this is normal but I need to fill in my mail address at the start of PSS often. I guess about every 5 times starting the program, so sometimes I need to to register at start every few days.

Using Ubuntu 16.04. BTW thanks for bringing PSS to Linux, it works so smooth!!


After registration install firejail and make a shortcut with "firejail --noprofile --net=none /usr/share/paintstorm/Paintstorm" as executable. It works for me. ;)



Actually, not matter what I try the parent shuts down right away. Even if I allow network. firejail --noprofile /usr/share/paintstorm/Paintstorm

Re: Need to register often

Posted: Wed Sep 13, 2017 8:59 pm
by Ico-dY
HeroicNate wrote:Actually, not matter what I try the parent shuts down right away. Even if I allow network. firejail --noprofile /usr/share/paintstorm/Paintstorm


It's a common apparmor bug: https://bugs.launchpad.net/ubuntu/+sour ... ug/1373070
Please, use "--protocol=unix” instead of “--net=none”. The effect will be the same disabling ipv4 and ipv6.

So the command should be:
"firejail --noprofile --protocol=unix /usr/share/paintstorm/Paintstorm"